Zum Inhalt springen

ajaxselectlist 4.0.0

Gestern habe ich eine neue Version von EXT:ajaxselectlist veröffentlicht. Die Extension unterstützt nun TYPO3 v8 und TYPO3 v9.

Durch diverse Änderungen im TYPO3-Kern musste ich erst die Unterstützung der Mehrsprachigkeit wiederherstellen. Beim Update müsst ihr im List.html Template ein neues Eingabefeld ergänzen:

<input type="hidden" name="id" value="{currentPageID}">

Diese Lösung ist als vorläufiger Workaround zu verstehen.

Mein Ziel ist es, den Ajax-Aufruf für die nächste Major-Version (5.0.0) auf die neu eingeführten PSR-15 Middlewares umzustellen. Ich muss aber erst die Zeit finden, mich mit dem Thema zu beschäftigen. Diese Version wird dann unter TYPO3 v9 und der kommenden Version 10 laufen.

Zur News-Übersicht